Ford Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
my friend has a 1963 galaxie with a 352 2bbl and a c4. the other day he took it out for a spin and the car died on him. we towed it back to his house and changed out the voltoge regulator,we polarized it, checked the battery for full charge and it is good and checked the generator to see if it was charging and it is; changed out the sparkplugs, ignition coil,and sparkplug wires. and we are still having difficulty getting it to start. when we try to start it the engine and it makes a sound like the starter is not getting enough juice to crank the engine over. earlier my friend took the starter off and tested it with the battery and the gear turned but he said it turned a bit slow pleeeeeease help somebody.
 

·
Registered
Joined
·
868 Posts
When you say it died...do you mean the engine cut out while running?or do you mean that it would'nt start again after he turned off with the key last?
 

·
Registered
Joined
·
868 Posts
bullitt2001 said:
the engine died while he was driving.
Well if the engine died while driving...that is'nt caused by the starter motor.There are exception's,but in most cases either there is a problem with the fuel system,or the electrical system.So possibly either fuel is'nt coming from the carburettor...or the spark plugs are not getting the correct spark if any.There are alot of other possibilities...but these are the most common fault's.Sometimes something simple like an old fuel filter can block up,and your engine will just die while you are driving...or a wire can just break off with age somewhere and cut off your ignition system.You have to find out what it's not getting and trace it back through the relevant system...Luke!!
 

·
63-1/2 Galaxie
Joined
·
323 Posts
Hi, some times the condenser in the distributor can fail, suggest you check it out or just replace it, they are cheap to buy. I've had that happen on my old Galaxie, but eventually I put in a pertronix ignition which eliminates points and condenser.
 

·
Registered
Joined
·
9 Posts
I would highly recommend installing pertronix in your car. I used to have problems similar to yours in my '67 Galaxie and the points were usually the culprit. Ive got pertronix in my '66 ford now and no problems.
 

·
Registered
Joined
·
917 Posts
bullitt2001 said:
my friend has a 1963 galaxie with a 352 2bbl and a c4. the other day he took it out for a spin and the car died on him. we towed it back to his house and changed out the voltoge regulator,we polarized it, checked the battery for full charge and it is good and checked the generator to see if it was charging and it is; changed out the sparkplugs, ignition coil,and sparkplug wires. and we are still having difficulty getting it to start. when we try to start it the engine and it makes a sound like the starter is not getting enough juice to crank the engine over. earlier my friend took the starter off and tested it with the battery and the gear turned but he said it turned a bit slow pleeeeeease help somebody.
On those things (y block) its usually the capacitor acroos the points , go find a replacement for the points ( you can get kits to replace them ) and forget it (used to be able to buy a transistor kit 20 years ago)
 
1 - 7 of 7 Posts
Top