Ford Forums banner

1 - 3 of 3 Posts

·
Mondeo Obsessed
Joined
·
89 Posts
Discussion Starter #1
Hi all,

Thanks in advance for helping me fix my radio and cruise control.!

I have the ST24 model of the 2000 Mondeo. The only non-standard electrical item is cruise, and the radio problem was happening before the cruise was installed. The car has an external aerial (not in the glass like BA falcons).

Ever since i've had the car, the radio crackles on AM only. FM reception is perfect.

If i press / tap (fairly firmly) onto the bottom left of the radio console, it usually stops. Also, occasionally tapping the brakes (just enoguh to put the light on, not to actually slow the car) will stop it happening.

Any ideas? Loose wire? How hard is it to fix?


Also, the cruise will often turn on but not 'arm' (set or resume speed) unless the brakes have been touched. It worked perfectly for about 100km then died. I had it professionally installed, but unfoprtunately it broke while i was away for work, and got back to town after the warranty expired. Now they want to charge me to look for the cruise fault. Needless to say, i wont be recommending them to anyone......

Thanks in advance.

James
 

·
BA'o'Matic 100% working.
Joined
·
3,838 Posts
Sounds like an earthing problem, increase the size of the wire from the negative terminal to the body and see if that helps.
 

·
Mondeo Obsessed
Joined
·
89 Posts
Discussion Starter #3
Dellboy999 said:
Sounds like an earthing problem, increase the size of the wire from the negative terminal to the body and see if that helps.

Thanks Dellboy :angel: , I'll give it a go and let you know!!! Will this (hopefully) work for both problems?
 
1 - 3 of 3 Posts
Top