Ford Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I hope i can get some help from the experts here for my 2000 F350. Its a 3/4 ton 4 wheel drive automatic. I purchased it used about 8 years ago. For the last 5 years the radio will just randomly turn on by its self or self switch from radio to cd. Not a big deal, i figured it needed a new radio unit. Then last winter it died in my driveway and would not start. Lots of cranking power as i had replaced my batteries. The dome light would not turn off. All The dash lights were stobing and flashing we disconected the batteries to stop it. I had it towed to a reputable diesel shop. They found and replaced something and 750.00 later the truck seems fine. For a while. It soon starts the wierd thing with the radio again. We walk by it one day on the way into the house and the dome light is on and the heater fan going full blast. Everything is turned off and the key is not in the ignition. Then one daY the windshield wipers come on and wont turn off. We removed the blade arms then it stopped. Then one day about 2 months later. We are at a station refuling and start it up and it refuses to leave park. Have it towed back to the diesel shop and they replace something in the stearing column and 750.00 later get it back. Now we are driving it, the radio is still acting up every so often, the turn signals will work sometimes just fine. Other times not at all. We are disconecting the batteries often as it seams to clear the problems for a while.
Today we go to a yard sale and get there and turn off the ignition and remove the key, and the engine continues to run. We get back home and i do a search and it tells us to remove fuse 24 to turn it off. The truck sits in our yard now. Afraid to trust it to go anywhere.
Now also i feel the need to mention, i live right next to a radio tower and 3 large cell towers last spring they upped the g from 4g to 5g. I had a well repair company come to maintenance our well 4 months ago and there well rig truck was a 1999 F 550. It died in our driveway in the same spot our truck did last winter. They said something about their truck did not like the high output of cell towers and there were a couple places they avoided as the truck would die everytime they passed to close.
I dont know if this is part of my problem or not. It would be pretty sad if i could not keep my truck because of the radio and cell towers nextdoor.
I love my truck. It is still a strong running diesel with low miles for its age. The 4 wheel drive is excelent. It has some rust issus but not bad. I dont think i can afford to have it taken in anymore and the diesel place guessing what is wrong or missing the Main problem. I am not mad at them, but hesitant for expensive fixes that are only temporary.
Sorry this has been so lenghty, but wanted to be specific on the symtoms of the truck. Any comments or ideas?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Update, i could not figure out how to edit my post.
The truck is a one ton.
The batteries are new Odyssey's with 950 cold crank.
Anybody have any ideas what is going on with this truck, or had similar issues?
 

·
Super Moderator
Joined
·
7,646 Posts
While EMF can effect electronics, it's typical results are usually making the device useless. As far as I know, it's not intermittent and if you are stil experience the problem in areas where no one else is having problems, I'd start looking for other reasons for you problems. This sounds a lot like wiring issues due to shorts and corrosion. I'd start with a couple of cans of electronic cleaner and start disassembling your connectors and examining wires. When you put the connectors back together, apply some dielectric grease.
 

·
Registered
Joined
·
7 Posts
Just a suggestion, but check ALL of your body grounds, inside and out. you could have a few that are loose and/or corroded causing intermittent contact. When grounded properly everything is normal, but then something jars it and contact is lost or not sufficient, things can back feed and cause a lot of mysterious things to happen. I had a back feed problem with a Crown Vic and it took me months to figure out that I had bad grounds going from the body to the frame on three different ground straps plus one ground strap that looked good, but when I touched it, it disintegrated. Once all was cleaned up and attached properly, I had no more electrical gremlins.

As I said, it's just a suggestion and may not be your problem.
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
4 Participants
NFortin1966
Ford Forums
Ford Forum is a community to discuss all things Ford. Check out our discussions on the Ford Escape, Mustang, Edge, F-150, Raptor, Explorer, Focus, Fusion, Fiesta and more!
Full Forum Listing
Top