Ford Forums banner

1 - 20 of 24 Posts

·
Forced Falcon
Joined
·
307 Posts
Discussion Starter #1
I am using penrite HPR30 but have found when engine is cold it is abit noisy but when it is hot is quieter, it gets oil pressure straight away but is noisey in bottom end area, car has done 53000kms and i was just wondering what oil other people are using and what results they were having, maybe the penrite is a little thick when cold.
 

·
Registered
Joined
·
453 Posts
havn't had any probs with hpr 30
 

·
345kw of V8 Windsor Power
Joined
·
2,784 Posts
Shell Helix Ultra 5W-40 here too, ran it on my old engine and the new rebuilt one without any problems.
 

·
Pro-M Distributor
Joined
·
401 Posts
My motor was rattling on initial start up. We believed that the motor was on it's way out (it has done a lot of km's) but I have been informed that the Ryco filters tend to drain back where as the Motorcraft ones dont. I am using HPR 30 in mine too. Will try it on my next oil change and post the results.
Shane
(Falcon City - Adelaide)
 

·
Two SC 61's = trouble
Joined
·
6,360 Posts
MrLandau said:
My motor was rattling on initial start up. We believed that the motor was on it's way out (it has done a lot of km's) but I have been informed that the Ryco filters tend to drain back where as the Motorcraft ones dont. I am using HPR 30 in mine too. Will try it on my next oil change and post the results.
Shane
(Falcon City - Adelaide)

In your case with high milage an oil 25/60 or around those numbers would possibly be better...
There are oils for high milage engines..
 

·
feed me hey
Joined
·
4,692 Posts
If your getting death rattles on startup throw out the supercheap ryco filter and get a decent one. I put a ryco on my eb - straight away it got death rattles and takes about a second to build up oil pressure. It almost sounds like a 6 cyl lol.
 

·
Pro-M Distributor
Joined
·
401 Posts
Im glad I'm not the only one who has found the problem with Ryco filters. The landlord has been buying and selling NF & NL ex - limo's and has struck the same problem.
 

·
Registered
Joined
·
1,067 Posts
I use penzoil 5w50 in my xr8 with the genuine motorcraft filter.The filters aren't expensive so i might as well use them.
 

·
need BOOST
Joined
·
272 Posts
I have used Castrol Synthetic R 5w30 last couple of times, seems OK, before that.

Interesting comments about Ryco oil filters. I have been getting noise on cold startup about 7-8000km's after oil changes (I change every 8-10,000kms) and have been using Ryco filters. I will try motorcraft next time...

DT
 

·
Registered
Joined
·
234 Posts
I got that rattle too with Ryco, switched back to Valvoline filter and all is good (not XR8 but 6cyl Falcon). K&N also do oil filters.
 
1 - 20 of 24 Posts
Top