Ford Forums banner

1 - 4 of 4 Posts

·
Grand Marquis Member
Joined
·
5 Posts
Discussion Starter #1
I have a '95 Grand Marquis that I need help with. When I scan for codes P0401 EGR flow insufficient detected shows up. I have replaced the EGR valve, EGR vacuum regulator, and the DPFE sensor. The ckeck engine light always seems to come on during acceleration. Has anyone else had this problem before?
 

·
Mustang SVO Member
Joined
·
14 Posts
code 401

First the computer monitors egr function through the dfe sensor and O2 change. Was the original DFE melted when it required to be changed? If so you have an early sign of a catalytic failure. If not you have a restricted EGR system plugged with carbon. If you can find an old speedometer cable inner cable use this to run down the egr port and the egr pickup port. Using a driill or by hand turn the cable until it appears to be cleaned. Squirt some carb spray down the ports and pickup port from the exhaust system. allow a few minutes to dry out and then reassemble the egr system. Clear codes and road test. It should not cause the light to activate. If the catalytic convertor is partially restricted replace it, clear codes, and road test.
fomocodoc
 

·
Grand Marquis Member
Joined
·
5 Posts
Discussion Starter #4
code 401 still comes back

The DPFE sensor wasn't melted. I took it all back apart, cleaned everything, reassembled it, cleared the code, and test drove. Light came back on after about 20 miles of driving. I'm pulling my hair out and I haven't got much left to pull. It's against my religion to take it to the dealer. Any more suggestions would be greatly appreciated.
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
2 Participants
mufflerbearing
Ford Forums
Ford Forum is a community to discuss all things Ford. Check out our discussions on the Ford Escape, Mustang, Edge, F-150, Raptor, Explorer, Focus, Fusion, Fiesta and more!
Full Forum Listing
Top