Ford Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I am also new to the forums

I just bought a 96 CV P74, it is a wonderful car. Loaded with the digi-dash and leather. Its got 66k miles on it and runs perfect. My question is reguarding a high pitched squeal the comes from the center console area, right behind the A/C controls and cup holder. It comes around after you have just gone wide open throttle to get on the highway or just playing around. Not everytime tho, the sound is very very annoying and changes in pitch somtimes. Now I thought it was a lose connecter on the thing that makes the chime noise when you put your key in, leave your lights on ect. So I tracked that down and unplugged all the connecters on the black box there. once i did that i got my "Truck Ajar" light on all the time and my break lights and blinkers stopped working. So I plugged all the connecters in except 1, the one that makes it ding, I left that out. And thought i had fixed the problem. So go get on it a little to test and not a peep... at the time lol. the sound is the same and I did'nt fix anything. So while it was making the sound I stopped the car and scrambled under the dash to see if I could zero in on it while it was going. and since I have eliminated the black box then I thought the A/C might be the culprit. As it was making the sound my heater was on, so I hit the off button and the sound stopped right away. then a few seconds later it comes back, so I turned my heater back on and it stopped again. So I know how to make it stop and its got to be somthing A/c related. I think it might be what looks like 2 vacuum diaphrams located under the cup holder. But I have no clue and am weary about pulling lines lose. It only does its somtimes after you nail the gas

somone please help, its driving me insane!. Sorry for the long post but I am telling all I know about this as to help you guys tech shoot this problem. If any other information is required then just ask and I will find the answer. I tried signing up for crownvic.net but the site always seems to be slow or not work at all. Thank you all in advance
 

·
Police Officer/Rescue Tec
Joined
·
274 Posts
HEY, it's the idle air control valve located on the rear of the engine(driverside) beside the throttle body. My 92 did the same thing for years until I finally solved it (by accident). It looks like a tiny air tank. It controls the air adjustments during WOT,a/c,rapid deceleration and such and it will vibrate with different pitches depending on how much air is needed or trying to. They are not cleanable so don't try it. Go get a new one, from a local parts store....not a dealer, they'll shaft you on the price.Let us know how it goes
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
I will go get a new one tomorrow and test it out, It makes since aswell. even if it does'nt fix it then it will take one thing out of the picture. Thank you very much Ryoder :priest:
 

·
Registered
Joined
·
6 Posts
I have a 2003 that will squeal sometimes when under wot. I tracked it down. It was the serpentine belt. It was slipping at high rpm's
:hy:
Blitzed said:
I am also new to the forums

I just bought a 96 CV P74, it is a wonderful car. Loaded with the digi-dash and leather. Its got 66k miles on it and runs perfect. My question is reguarding a high pitched squeal the comes from the center console area, right behind the A/C controls and cup holder. It comes around after you have just gone wide open throttle to get on the highway or just playing around. Not everytime tho, the sound is very very annoying and changes in pitch somtimes. Now I thought it was a lose connecter on the thing that makes the chime noise when you put your key in, leave your lights on ect. So I tracked that down and unplugged all the connecters on the black box there. once i did that i got my "Truck Ajar" light on all the time and my break lights and blinkers stopped working. So I plugged all the connecters in except 1, the one that makes it ding, I left that out. And thought i had fixed the problem. So go get on it a little to test and not a peep... at the time lol. the sound is the same and I did'nt fix anything. So while it was making the sound I stopped the car and scrambled under the dash to see if I could zero in on it while it was going. and since I have eliminated the black box then I thought the A/C might be the culprit. As it was making the sound my heater was on, so I hit the off button and the sound stopped right away. then a few seconds later it comes back, so I turned my heater back on and it stopped again. So I know how to make it stop and its got to be somthing A/c related. I think it might be what looks like 2 vacuum diaphrams located under the cup holder. But I have no clue and am weary about pulling lines lose. It only does its somtimes after you nail the gas

somone please help, its driving me insane!. Sorry for the long post but I am telling all I know about this as to help you guys tech shoot this problem. If any other information is required then just ask and I will find the answer. I tried signing up for crownvic.net but the site always seems to be slow or not work at all. Thank you all in advance
 
1 - 5 of 5 Posts
Top