Ford Forums banner

1 - 14 of 14 Posts

·
Bronco Member
Joined
·
69 Posts
Discussion Starter #1
Hello,
My '83 cruise control and horn seem to be out...Hmm..they worked before. What do you think? I didn't see a fuse out...but last month I lost my taillights due to a blown fuse.

any ideas?

tx,
remat457
 

·
Bronco Member
Joined
·
69 Posts
Discussion Starter #3
fuse for horn/cruise

hello,
didn't see a fuse on the panel....

any body know where it is?


thanks,
reg
 

·
Probe GT Member
Joined
·
5 Posts
I used to have an '88 Bronco eddie bauer, i had the same problem, i had a radar detector hooked into the cigarette lighter and that didn't work either. it was a fuse for me, but i'm not exactly sure which fuse it was, you could check in the owner's manual for the fuse chart, i'm not entirerly sure which fuse it was because it happend a couple years ago.
 
B

·
Guest
Joined
·
0 Posts
it is definitly a fuse i had one go out in each of my trucks it is just that i dont remember on the 81 but in the 90 it is under the steering wheel.
 

·
Bronco Member
Joined
·
31 Posts
Fuse...

In my '86, the horn, fuse and cruise control all share a fuse, located in the fusebox near the brake pedal. A 20 amp fuse.
 

·
F-250 Member
Joined
·
42 Posts
yeah they do share a fuse but take out the glove box and reach into the right of the dash and there is somthing that looks like a little box with like 5 prongs in it and that could be why the horn is out too but try it it might help maybe
 

·
Bronco Member
Joined
·
69 Posts
Discussion Starter #9
fuses keep blowing

hmm...

replaced 3 fuses about a month ago and it seemed to fix everything! (horn, cruise, blower, dash, etc)

but...to my behold it seems to have popped the dash again...
where to start???
 

·
Bronco Member
Joined
·
69 Posts
Discussion Starter #10
yep...

yep...everything else seems to be ok, but
the dash light fuse pops everytime i put a 15amp in (like as soon as i turn the lights on!)

any ideas?
 

·
F-150 Member
Joined
·
141 Posts
If your dash is out, your tail lamps are probably out too. Start by checking the tail lamps, license plate light and the most probable cause a trailer hitch wiring.

Let me know how you make out...
 

·
Bronco Member
Joined
·
69 Posts
Discussion Starter #12
tailer hitch wiring

The tail lights were out also. I replaced that fuse and it seems to be doing ok (fingers crossed). But the dash fuse pops everytime the lights go on....

You think the trailer hitch wiring harness is the culprit? Do you think that it is grounding out?

thanks!
 

·
F-150 Member
Joined
·
141 Posts
remat457,

I would sure look at the trailer wiring. At my shop the majority of tail lamp repairs with trailer hitches, is over 50% caused by the trailer wiring. I would definatly check it out first. Then If that all seems OK pull the tail lamp assembles out and look at the sockets and bulbs. Any of them leak water??

Let me know.
 

·
Bronco Member
Joined
·
69 Posts
Discussion Starter #14
trailer harness, dash, and taillights

Well, the tail/brake lights seem to be ok.
The dash is still out (still pops the fuse as soon as i turn the lights on).

BUT, i checked the voltage on output on the trailer harness below the hitch and it is dead.

:(
 
1 - 14 of 14 Posts
Top