Ford Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
hey guys, may be a silly question but im think that i need some new foam for more horn... last night at 3 in the morning my horn just started sounding and wouldn't stop til i unplugged the battery. it happened a couple of months ago aswell but stopped as soon as i put the key in the ignition. as far as im aware (from what i've read and heard) there are a couple of wires separated by a bit of foam and if that foam disintigrates then you cop a rude awakening like i did last night! can anyone confirm this and where/how to fix?? thanks heeeeaps!

btw its a 94 ed classic
 

·
Sandwich Connoisseur
Joined
·
955 Posts
Just cut yourself a new bit of foam. Get the old piece out and take it to clark rubber and get them to do the rest.
 

·
Territory TS - AWD
Joined
·
2,374 Posts
Yep, happened to mine too (ED not Territory).

There is a thin splice of foam the seperates the horn contact plates. Once it desintegrates (~10yrs in my case) the plates can come into contact as if you are pressing the horn.

Just stuff some more in there, I used a piece that I ripped off an old sponge.

It takes all of 5 minutes and it should be good for another 10 years.
 

·
Super Moderator
Joined
·
3,817 Posts
From experience the double sided self adhesive foam tape used to attach car trim also works Ok too (but it is a bit stiff needing firm pressure on the horn boss to blow the horn). The rolls of draught excluding self adhesive foam tape (buy from any hardware store) is better.
 

·
Registered
Joined
·
1 Posts
hey guys, may be a silly question but im think that i need some new foam for more horn... last night at 3 in the morning my horn just started sounding and wouldn't stop til i unplugged the battery. it happened a couple of months ago aswell but stopped as soon as i put the key in the ignition. as far as im aware (from what i've read and heard) there are a couple of wires separated by a bit of foam and if that foam disintigrates then you cop a rude awakening like i did last night! can anyone confirm this and where/how to fix?? thanks heeeeaps!

btw its a 94 ed classic
Did you ever figure out the solution? I have the same issue. Mechanics disabled horn but several things do not work now because of it.
 

·
Super Moderator
Joined
·
22,258 Posts
Did you ever figure out the solution? I have the same issue. Mechanics disabled horn but several things do not work now because of it.
You have tagged on to a post over 16 yrs old with no chance of getting a reply from the op . Start a new post if you are looking for help in the correct section for whatever vehicle you have .
 
1 - 9 of 9 Posts
Top