Ford Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
206 Posts
Discussion Starter #1
well, not really, but its seriously p#ssing me off.
i had to sit in it for three and a half hours today, twice waiting for a RAA roadside assistance patrol (1 hour each) and a tow truck (1 and a half hours).
I had the car out on saturday night, and we started havin problems with it blowing the engines fusible link. went through about 6 of them to get us home. it says "30 amps" on the cover, so i was using those. then i read in the owners manual use 40 amp fusible links. so i go out and buy one, and all seems fine and dandy.
so i think to myself, what the hell, i'll take it to work and see how it goes.
middle of a busy intersection in the city, 3.30pm, lotsa traffic, engine dies. so i push it onto the median strip, flik on the hazards, and wait.
so the RAA guy replaces the fuse. engine turns, wont start. he says its got no fuel. i say bollocks, it has. turns out my fuel pump relay has also shat itself.so he bodgeys that up. while we are figuring that out, the starter motor starts cutting out. the guy plays with the relay, says that'l get you home,and to an auto electrican. see ya.
less than a kilometre from my house, it dies again. fusible lnk dead, bodgied-up fuel pump relay dead, and very hot. i replace the fusible link, and put a wire across the relay connections, lotsa sparks and a dead fusible link. again.
so i give up, walk home and have a cold shower. then i called the raa. i want my car towed. ok, but we have to send a patrol out first. grrrrr....
an hour later, the same RAA guy rocks up. i tell him what happened. he says, i'm not even gonna bother lookin at it, then goes to his van and organises a tow truck. 1 and a half hours later, the truck arrives, literally 5 minutes later its in my driveway.
who wants it before i torch it? lol
tomorrow i have to call the warranty company. i'm sure that will be as fun as todays effort....
sorry about the long post. cheers, phil
 

·
Registered
Joined
·
7,505 Posts
damn, not much luck there, hopefully its smimply a simple fix :)
fuses shit me ;)

my wrecked ghia wouldnt start coz of a damn fuse!
 

·
E-Series wagon owner
Joined
·
1,929 Posts
i'll have it b4 you torch it!!!
i'll use it for parts! but then again prolly not cause my car'll proly break down with that cars parts in it :s5 lol :s5
 

·
400 kg ego
Joined
·
6,188 Posts
That's really strange... you'd think someone had installed an ultra high voltage battery or something. :ihi:

Let us know how you go.
 

·
BA'o'Matic 100% working.
Joined
·
3,838 Posts
Fuses normally blow becuase of a short, check that no wiring is stiing against the bod anywhere and rubbed through.

Alternator putting how to much current, would cook the battery over time, get a test on it.

P.S. I will take it off ya hands before ya torch it :)

Jason
 
1 - 5 of 5 Posts
Top