Ford Forums banner

1 - 6 of 6 Posts

·
Mark VII Member
Joined
·
5 Posts
Discussion Starter #1
I completed the big project this weekend but it just don't seem right.
What I did was to change to after market heads with 1.94 intake and 1.60 exhaust valves, FMS Cermaic coated shorty headers, Cobra intake, FMS 65mm throttle body, and FMS E303 cam. Every thing went well no leaks no extra parts and all the hoses and connectors made it back where the go.
Now to the problems since I changed the throttle body are there any adjustments I need to make, and how do I adjust what looks like an idle adjustment screw or throttle stop screw that's on the throttle body.
If anyone is running the E303 cam what is a good setting for the ignition timing.

Thanks
BigDon
 
F

·
Guest
Joined
·
0 Posts
Don are you running the stock speed density system?
If so you will have problems getting the car to idle properly with that E303.I can only suggest adding the Ford idle air bypass kit
which will help considerably.It is a $20 part from Steeda.com.
It allows more air past the the IAB and therefore some additional idle adjustment which you will probably need.
 

·
Mark VII Member
Joined
·
5 Posts
Discussion Starter #4
FLA-LSCSE,
I did the mass air flow conversion about a monyh ago. I wanted to be sure it worked before I did the big project.
It took a little while for it to idle last night and I dicked with the adjustment screw on the throttle body. When I took it for a drive it seemed flat and kinda chuged when I was slowing down.
I can't find any info on that adjusting the screw on throttle body (looks like an idle adjust screw) and would like to set it up correctly. I understand the computer controls the idle. I can't figure what that screw is used for but I tweeked the hell out of it last night and want to get it set up right.

Don
 
F

·
Guest
Joined
·
0 Posts
Don have you reset and checked the timing since the swap?Both JYD and I think it may be timing related or worse you may not have the cam installed properly(did you install it "straight up")?
 

·
Mark VII Member
Joined
·
5 Posts
Discussion Starter #6
The timing is @10btd, the car sounds great at idle but I think tweeking with that screw I leave the throttle open and am kind of leaning to it's a fuel system problem.
How do I set up the throttle position sensor?
If I disconnect the idle bypass valve would I us the screw for a base idle
 
1 - 6 of 6 Posts
Top