Ford Forums banner

1 - 8 of 8 Posts
G

·
Discussion Starter #1
Have a '89 with a 302. Good battery(had tested) and just replaced ignition switch located on steering column. What it is doing is not starting. You turn ignition and radio and dummy lights come on but when I turn it all the way to start nothing happens. Can anyone give me a good next step or steps.
 

·
Registered
Joined
·
7 Posts
lack of ignition?

well, a month has gone by, so i should hope that your problem is fixed now. If you dont mind me asking, what was the problem? I myself just ran into a problem with my ignition last week....
 

·
Grand Muckety Muck
Joined
·
710 Posts
Is the motor cranking, and jsut not turning over or is there nothing happening at all?
 

·
Registered
Joined
·
1 Posts
i've got an '88 bronco, no fuel pressure and no spark. all ignition components are new all fuseable links are good , new pickup coil, new fuel pumps. it was setting idling and just quit like you shut the key off, now its been a month and i still cant figure it out. computer maybe? PLEAS HELP !!
 

·
Always the student
Joined
·
1,739 Posts
phillybhw said:
i've got an '88 bronco, no fuel pressure and no spark. all ignition components are new all fuseable links are good , new pickup coil, new fuel pumps. it was setting idling and just quit like you shut the key off, now its been a month and i still cant figure it out. computer maybe? PLEAS HELP !!
Definitely need more info. What do you mean all ignition componets are new? We really need to know what they were. Is the vehicle cranking but not starting? ( I assume so, since you say no spark)Can you hear the fuel pump come on? Sounds most likely electrical. Have you checked/replaced the ignition module?
 

·
Registered
Joined
·
4 Posts
poss computer,need more info, mayb try a scan tool, rent or borrow, make sure its for old eec plug under hood. is it turning over?check timing, check maxi fuses and in cab fuses, last 4 now, check fuel pump reset
 
1 - 8 of 8 Posts
Top