Ford Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2 days ago I was cleaning out my car and killed the battery by having radio going for way too long. It jump started easily and has been starting and running great. BUT--the touchscreen is now very wonky. Some buttons work, others don't do anything when pressed. In addition, the control panel for the climate and radio(just below the touchscreen) will not work at all--no lights and no beep when buttons are pressed, and the volume dial is no functioning. The fan is blowing very warm and on highest speed and nothing that I've tried will allow me to adjust this. I would like to at least troubleshoot the issue myself before taking it in to a shop for repairs I can't afford. Anybody have any ideas? This is my first visit to the forum and from what I'm reading, there are some really bright people here who might be able to help me.
 

·
Super Moderator
Joined
·
809 Posts
Have you tried disconnecting the battery to reset everything?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I haven't tried it yet. This was my first stop to get some ideas before I did something stupid that would make things worse. I'm heading out to try it right now. Thank you!
Jode
 

·
Super Moderator
Joined
·
19,178 Posts
Your car may be in battery saver mode due to the battery being run down . Jump starting the car will not normally reinstate battery to full capacity . You really need to fully charge the battery . In low battery state , non essentials are cut off till sufficient power is back in battery .
 
1 - 4 of 4 Posts
Top