Ford Forums banner

1 - 7 of 7 Posts

·
Mod/Crown Vic Cruiser
Joined
·
129 Posts
Discussion Starter #1
Hello,

My name is Jonathan and I am from Western NY. I was referred here by Tim L. I am the Moderator of the 1992-1997 Crown Victoria Forum. I am a college student and part time Auxiliary Police Officer. I own a 1993 CV LX with 91,000 miles. It is grey with grey interior. I plan on running duals this summer and various other mods... if anyone else here knows about being a college student, money is at a premium so Modding comes in the summer when I work full time. I look forward to meeting everyone and Happy Posting!

Jonathan
 

·
Mod/Crown Vic Cruiser
Joined
·
129 Posts
Discussion Starter #3
Yeah, Nice car.

My brother owned a 93 Probe Gt... I loved it... it was fast (5 speed) unfortunatly is was almost all plastic and fell apart inside.. so he abandoned it for a Town car.... go figure...

Jonathan
 

·
Old Skool Member
Joined
·
1,031 Posts
Hmmm I don't know what was wrong with his interior but mine has held up great, and it's 11 years old now. :)

And that's even after a few stereo installs involving pulling apart interior pieces. (Although I need to get some new clips and tabs)
 

·
Registered
Joined
·
7,859 Posts
Hey Vulcan, there is a big differance from the 1 gen interior and the 2nd gen. I had a 89Probe, interior was perfect, 93-94 Probes the door panels will fall off eventuly. The center concil is nothing but clips holding the thing together, very easy to break if your not careful.:(
 
P

·
Guest
Joined
·
0 Posts
Jonathan said:
Yeah, Nice car.

My brother owned a 93 Probe Gt... I loved it... it was fast (5 speed) unfortunatly is was almost all plastic and fell apart inside.. so he abandoned it for a Town car.... go figure...

Jonathan
Ive heard people selling their probes for different cars but NEVER heard someone getting a Town Car after a PGT. I guess your brother musta been doing some serious pimping... :)
The interior is not so bad in 93--94s...
 

·
Mod/Crown Vic Cruiser
Joined
·
129 Posts
Discussion Starter #7
Well, He claimed he got the fast driving out of his system and was ready to retire down... (ps....he is 21) Well, he wasnt super gentle to the interior. But the door panels were close to falling off. And it had the CD player.... One thing I will always remember about this car was it had the factory subwoofer in the trunk. When he bought it used, it didnt work. He took it apart and nothing. So he left it alone. Well, 7 months after he bought it, we went on a camping trip to the Alleghany Mountains. We were listening to a nice CD, and we are driving up the side of a mountain and as soon as we hit 3500 feet.. there was this thumping from the trunk. We stopped the car and sure enough the sub was working! Well, when we drove down the otherside, it stopped... SO we went up and down the mountain a couple times, and everytime it worked. When we returned to my home city (elv. 250) it never worked again. interesting huh???

Jonathan
 
1 - 7 of 7 Posts
About this Discussion
6 Replies
5 Participants
Jonathan
Ford Forums
Ford Forum is a community to discuss all things Ford. Check out our discussions on the Ford Escape, Mustang, Edge, F-150, Raptor, Explorer, Focus, Fusion, Fiesta and more!
Full Forum Listing
Top