Ford Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I tried to start my Edge this morning and wouldn't turn over or start. Heard what I thought was normal solenoid clicking. Turned key off and going to check the battery when the clicking continued without a key in the ignition. The clicking went on for several seconds. Door chime continued as if key was in the ignition. Tried to jump start but wouldn't turn over. After several attempts, I lose all power and I hear clicking coming from the fuse box. I tried switching out the start relay, but no luck. It is dead in the water with no power whatsoever. Ideas?

Thanks,

Mike
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
I tried to start my Edge this morning and wouldn't turn over or start. Heard what I thought was normal solenoid clicking. Turned key off and going to check the battery when the clicking continued without a key in the ignition. The clicking went on for several seconds. Door chime continued as if key was in the ignition. Tried to jump start but wouldn't turn over. After several attempts, I lose all power and I hear clicking coming from the fuse box. I tried switching out the start relay, but no luck. It is dead in the water with no power whatsoever. Ideas?

Thanks,

Mike
A new battery fixed the problem! Strange, since it wouldn't jump start.
 

·
Super Moderator
Joined
·
20,542 Posts
Had that scenario many times on breakdown callouts on non starts due to battery being so low , quite common . Thanks for updating the forum .
 
1 - 3 of 3 Posts
Top