Ford Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Mazda forums are pretty inactive, it appears this isn't.
hopefully you can help me out a little bit. Since it's the same motor. Among other things I guess. I'll get to the point.
My sister has a 93 626 V6 auto. It wouldn't start the other day. Put a new fuel filter on, it was a cheap guess. Started right up. So I was warming it up, making sure it was OK. I went through the distributor issue already, and didn't want to tow it again.
I walked out of the garage while it was running. When I came back less than 5 minutes later, it was knocking. Checked oil, not low. It's coming from the rear cylinder head. Sounds like cylinder 5, but hard to say for sure.
Is there any common weak point up there? Just looking for ideas before I tear in to it.
Almost forgot, it's got about 165k miles on it.

Sent from my SPH-M820-BST using AutoGuide.Com Free App
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
It's not a rod knocking. I pulled plug wires one by one with no change. Not an injector. It's definitely top end though. Maybe you could call it a tapping type noise. It's a loud tap, or a quiet knock. Six of one, half dozen of another. I thought maybe, for example, valves bend. Or lifter problems are common. It's too cold here, so I won't be getting to it for a couple weeks. But if when I do get in there, there's something I should look for. It would be appreciated.

Sent from my SPH-M820-BST using AutoGuide.Com Free App
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Going to try that. But I had a thought today. Are there any sort of baffles on the valve cover? I'm thinking, if there are, it may have come loose, and the cam lobe is hitting it.

Sent from my SPH-M820-BST using AutoGuide.Com Free App
 

·
Super Moderator
Joined
·
7,733 Posts
Never seen baffles in them, but I've not seen them all.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
That's what I'm talking about. There's that extra plate on there. It appears to for the pcv valve in the pic. But does the rear one has something similar? Do you know?
Also, I just a compression test. I don't know if my gauge is correct, but I got 125-130psi on all 6 cylinders. So I don't think it's a valve issue.

Sent from my SPH-M820-BST using AutoGuide.Com Free App
 

·
Super Moderator
Joined
·
19,293 Posts
Psi's are all even , not bad for year and mileage , wont be a valve .Never known or heard of any plate on cam cover coming loose or causing knock .But there's always a first .If it's at the top end , I would think it's more likely to be a hydraulic tappet / lifter sticking .Remember and use a good synthetic oil if changing oil and fliter .
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
Thread revival!
My knock is still there. I ended up taking the valve covers off to see what I could see. Found nothing, so I tried some Kreen. That hasn't helped at all. My diagnosis is a bad lifter or multiple bad lifters. At $27 each, I can't throw 12 at it and be done. Is there a way I can inspect them?
Another detail I forgot to mention, a heater coolant hose was blown. And the car was driven for about 5 miles. That was the start of it all.
Thanks for the help.

Sent from AutoGuide.com Free App
 
1 - 10 of 10 Posts
Top