Ford Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I just replaced the stereo in my 2003 Mercury Grand Marquis I won on auction and fixing up. After that I ended up having issues with the driver side lock. It wouldn't unlock the door when the key was turned and not running previously, which was odd but not concerning. But after that radio was installed and seemed functioning late in the morning I went to lock up and wish myself a job well done.

Well now the lock buttons will not lock any of the locks and the interior lights, AC, stopped working. If I press the unlock button I can see the clock power on, and I can turn off and on the map lights by pressing the button but the AC does not want to power on now.

I assume the switch is bad but does that really control so many things from that driver side lock switch? I ordered a replacement but it says for cars without keyless entry but no other option but Motorcraft that states nothing about keyless entry or not.

Ordered a new driver side switch hopefully this fixes the issue but anyone seen this happen before? Does the Light Control Module control the interior lights or AC control? Wondering if that has any bearing as well.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
So its definitely blowing fuse 23 so maybe it is the driver lock switch which I ordered as well since happens seems when I try to lock the door. Else the radio may be blowing it.
 

·
Super Moderator
Joined
·
20,061 Posts
Fuse #23 does seem to cover all your faults ,

23152003-2004: EATC module, Instrument cluster, Clock, LCM, Interior lamps, Door lock switches, Door ajar and roof lamps (Taxi vehicles)
2005-2012: Multi-function switch (Flash-to-pass), LCM (High beams; 2006-2012)

Possible the wiring where it passes from A frame into the door is damaged / broken and shorting ?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks for the tips. Did some more work last night and looks like the passenger side lock switch is causing an undue load. I unplugged it and all works as intended with a new fuse.

I already thought was the driver side lock switch and bought that one but looks like I should of bought the passenger one.

Will leave it unplugged for now. Electrical issues are not fun to work though but at least so far has only been switch replacements instead of digging into wiring.
 
1 - 5 of 5 Posts
Top