Ford Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
So I have a 2011 Ford Crown Victoria Police Interceptor I'm having an overheating issue with I've replaced the thermostat the cylinder head temp sensor the water pump and the radiator fan and it still overheating my next guess is that it is the radiator....maybe needs cleaning?? Any suggestions??
 

·
Super Moderator
Joined
·
1,448 Posts
Stop throwing parts at it and do a block test. That will at least narrow the issue down.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Not losing any liquid....I've done everything now except change out the radiator but I did pull the radiator an give it a good cleaning of the fins an what not....still same results....no cel or nothing just over heats....I'm at a loss...maybe the motor is just tired an has had enough maybe??
 

·
Super Moderator
Joined
·
1,448 Posts

This shows you how to perform a block test.

Did you clean out the inside of the radiator? It could be clogged.


Sent from my iPhone using Tapatalk
 

·
Super Moderator
Joined
·
22,592 Posts
Impossible for cyl head gasket to be leaking and not lose some coolant . It's the internal tubes that get clogged in radiator causing overheating more so than the fins
 

·
Super Moderator
Joined
·
1,921 Posts
I agree with Logan, especially if you have not been using coolant and distilled water. Over time the minerals in hard water will clog the cooling tubes in a radiator.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #10 ·
Yes I've flushed the entire system an water flowed through it perfectly..a friend told me it could be air in the system..like I need to "burp" it. I'm not tooooo savvy with auto work so I have no idea... but yea im not losing any fluid at all either...
 
1 - 10 of 10 Posts
Top