Ford Forums banner

1 - 4 of 4 Posts

·
Project Falcon
Joined
·
9 Posts
Discussion Starter #1
Hi All, I just installed a police cluster into my AUII, the cop car was a V8 and my AUII is an I6. The problem is the radiator light comes on. I've checked the cooling system and it is fine. According to the manual the sensor was in V8's only. Any suggestions on how to fix this annoyance would be appricated.
 

·
Got my 3.45 LSD!
Joined
·
214 Posts
i didnt think that a high series or v8 cluster was compadable with an i6 because of the volts and oil gauge and the added cluster lights.
 

·
Registered
Joined
·
44 Posts
This may not be relevant, but the radiator/overheat warning light on my mothers AU I does come on intermittently even when the temp guage shows normal running temp. She had it checked by a sparky, and he said it was just a minor fault in the thermostat, and that it shouldn't effect the ECU (there were concerns it would set off the Systematic Cylinder Shutdown System by the management system). I beleive she had it fixed recently when she was a little more flush.

Perhaps during the install a wire got loose and is tricking the guage to read wrong?
I dunno, just thought I'd let you know of AU's with similar problems..
 

·
Got my 3.45 LSD!
Joined
·
214 Posts
Broken_suave said:
This may not be relevant, but the radiator/overheat warning light on my mothers AU I does come on intermittently even when the temp guage shows normal running temp. She had it checked by a sparky, and he said it was just a minor fault in the thermostat, and that it shouldn't effect the ECU (there were concerns it would set off the Systematic Cylinder Shutdown System by the management system). I beleive she had it fixed recently when she was a little more flush.

Perhaps during the install a wire got loose and is tricking the guage to read wrong?
I dunno, just thought I'd let you know of AU's with similar problems..

ive had that warning light come on when the temp gauge is normal. easiest way 2 get rid of it switch your car off, wait 10 or so seconds, then turn your car back on. goes away everytime. if not, pop the bonnet and check coolant level to see if the light is coming on for a reason.
 
1 - 4 of 4 Posts
Top