Ford Forums banner

1 - 4 of 4 Posts

·
Two SC 61's = trouble
Joined
·
6,360 Posts
Discussion Starter #1
I have had troubles with my power steering pump no end.I tried to do it on the cheap, you know the Mrs says spending MORE money.Bought a second hand one.Any way the thread is stuffed in the shaft so I can't pull the pully on.After new one cheeeeeze!!Cheap is Not always best
 

·
T5 Expert Operator
Joined
·
6,540 Posts
ebxr8240,

You mentioned that to me on the club meeting on tuesday, and you got the part from that Smithfield place. What's actually wrong with the pump in the first place??? Is it leaking or the pump is literally stuffed?
 

·
Two SC 61's = trouble
Joined
·
6,360 Posts
Discussion Starter #3
Man am I pissed.Yea the pump itself is o.k but the thread in the main shaft is stripped and its impossible to pull the pully over it.I borrowed a tool but the bolt was a bodgy "mild" steel and broke off in there[Farrk].Well after much,much hassle I got it out.The thread is stuffed right from the start, I think. Being hardened it is impossible to clean up.So now monday I'll be after a new one.the original was broken mysteriosly when I machined the heads to increase compression to 58 cc chambers.I would say it fell off the table or something,but when you were a kid would you own up?May even need get another pulley as well, at $82. a shot.Oh well back to Thomson Ford...Again!! So much for a ten minute job...should be..
 

·
T5 Expert Operator
Joined
·
6,540 Posts
Thats no good, yeah i thought my case was bad, i got my power steering system flushed and the fluid was brown they had to flush it 3 times. Well hope you sort the problem out mate.
 
1 - 4 of 4 Posts
Top