Ford Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2,650 Posts
Discussion Starter #1
the CFI EA is playing up,problem is that when driving her she was revving higher then usual,but it was when i turn the key off it starts coughing and spluttering etc then BANG big puff of smoke out the rear muffler,i changed accelerator cable as the pedal had no response and seemed to make it stick abit,but its still doing it so my mechanic has disconnected the idle solenoid thingo under the carby,but it still does it..

what can it be?

im looking at maybe its timing but i told my mechanis to check that,and he hasnt said anything about it,he says to keep a eye on it.

im now worried about the car,can it still be timing,or can that idle solenoid/sensor thingy being faulty???

or maybe the cars running rich (doesnt feel like it though except the higher then normal rev whilst idling) and may need a good tune up???

any one help me out and tell me if they know what it may be or if they have had similar problem..

i need to get this problem fixed asap

any help is appreciated

cheers
 

·
Registered
Joined
·
49 Posts
If the engine is idling high when u switch it off it could cause pre ignition as u have described.

It may need a new TPS.

What revs does it idle at before u switch it off?
 

·
Registered
Joined
·
2,650 Posts
Discussion Starter #3
well i dunno as its not a rpm tacho dash..

its when i stop in (D) whilst in gear,and revs abit higher again if you put in in (N) or (P)
then when i switch it off its does the spasm thing..
 

·
Two SC 61's = trouble
Joined
·
6,360 Posts
Iac senser is sticking or idle screw is turned up to high..Check for inlet leaks or vacuum lines off...Make sure there is some slack on throttle cable...
 

·
Registered
Joined
·
2,650 Posts
Discussion Starter #5
ok i found its only pre igniting after it gets warm which leads me to believe its maybe cause the cars getting hotter cause its revving 1000 to 1500 rpms more then normal..

im changing idle solenoid thingy and a new thermostat and see what happens...
 

·
Registered
Joined
·
1,512 Posts
a friend of mine had the same problem with his race car, XU1-GTR Torana, it got up to 220+++ degrees after racing and it wouldnt turn off. The water filled AutoMeter temp gauge (very expensive) went all the way around, and broke the dial....they had to pull the coil lead off for it to turn off
 

·
Ford Member
Joined
·
103 Posts
Your timing is too far advanced my cortina used to do that on Petrol because timing was advanced for it to run on LPG.
 
1 - 7 of 7 Posts
Top