Ford Forums banner

1 - 11 of 11 Posts

·
kez56
Joined
·
13 Posts
Discussion Starter #1
Not sure if this is the right forum to post into but here goes. I am having a few probs with my EF XR8.

1) Checked the transmission fluid stick the other day. Level okay but have noticed a light brown milky sort of fluid at the end of the stick.

2) Checked coolant reservior and found coolant had changed into a thick milky brown consistency (looks much the same as what I found on the transmission fluid stick). I took the cap off (engine was cold at the time) and this fluid just started pissing out every where. The next day all that was left on the driveway where it landed was a substance that was clear and slippery but does not smell. I have checked the oil level as well and this is okay.

3) Turned the ignition on and found that when placed into 1st gear (its an auto) and I accelerate, it is almost as though the car is in neutral. It will rev out to about 4k and will "kick" into gear,

Any thoughts or comments are appreciated. Please note that I am not very technically minded when it comes to cars. I bought my XR purely because I have always loved them and with no intention of modifying it. I guess I need to know whether I have a major problem here or is this something really simple that I can fix with a bit of guidance.
 

·
Ford Veteran
Joined
·
685 Posts
kez56 said:
Not sure if this is the right forum to post into but here goes. I am having a few probs with my EF XR8.

1) Checked the transmission fluid stick the other day. Level okay but have noticed a light brown milky sort of fluid at the end of the stick.

2) Checked coolant reservior and found coolant had changed into a thick milky brown consistency (looks much the same as what I found on the transmission fluid stick). I took the cap off (engine was cold at the time) and this fluid just started pissing out every where. The next day all that was left on the driveway where it landed was a substance that was clear and slippery but does not smell. I have checked the oil level as well and this is okay.

3) Turned the ignition on and found that when placed into 1st gear (its an auto) and I accelerate, it is almost as though the car is in neutral. It will rev out to about 4k and will "kick" into gear,

Any thoughts or comments are appreciated. Please note that I am not very technically minded when it comes to cars. I bought my XR purely because I have always loved them and with no intention of modifying it. I guess I need to know whether I have a major problem here or is this something really simple that I can fix with a bit of guidance.
2) sounds like head gasket is gone :(
 

·
Registered
Joined
·
39 Posts
kez56 said:
Not sure if this is the right forum to post into but here goes. I am having a few probs with my EF XR8.

1) Checked the transmission fluid stick the other day. Level okay but have noticed a light brown milky sort of fluid at the end of the stick.

2) Checked coolant reservior and found coolant had changed into a thick milky brown consistency (looks much the same as what I found on the transmission fluid stick). I took the cap off (engine was cold at the time) and this fluid just started pissing out every where. The next day all that was left on the driveway where it landed was a substance that was clear and slippery but does not smell. I have checked the oil level as well and this is okay.

3) Turned the ignition on and found that when placed into 1st gear (its an auto) and I accelerate, it is almost as though the car is in neutral. It will rev out to about 4k and will "kick" into gear,

Any thoughts or comments are appreciated. Please note that I am not very technically minded when it comes to cars. I bought my XR purely because I have always loved them and with no intention of modifying it. I guess I need to know whether I have a major problem here or is this something really simple that I can fix with a bit of guidance.
Hi kez 56!! Sounds like a tranny cooler to me. Get your radiator pressure tested!! You will probably need a tranny service as well! (Water & clutch packs do not mix well together) Let us know how you get on.
 

·
known as tibbo
Joined
·
2,033 Posts
yeh the radiator is FUBAR..The tranny plumbing is now mixing with your engine cooling system..Not expensive if you get to it now...a new radiator, some fresh coolant and a trans flush,filter and gasket...Don't drive the car or you will start to burn the inards of the transmission as the oil is now not cooling and lubricating but just swirling around doing nothing but agitating itself into coffee milk.. As ELGT4me said the clutch packs will slip and burn out

GEt it fixed ASAP or you will also need a head gasket, new rubbers hoses (every single one- radiator, heater hoses, heater tap ) and a transmission aswell.. THe oil in your water causes all the rubber hoses to soften and swell, eventually blocking your smaller diameter hoses shut, causing major engine overheating dramas..

The tranny will not come back to 100% immediatley.. remove the radiator, flush the cooling system a few times (without the new radiator plumbed in).. Flush the transmission of all the soiled oil<-- there is a thread on how to do this) install your new the radiator, and a new header tank (as you'll never get the oil residue out of the old one) and then over normal driving conditions the last of the water in the trans will eventually evaporate..<--similar to the puddle that was left under your car, the oil stays and water goes..



I can't stress how important it is to replace your radiator ASAP..
 

·
Registered
Joined
·
847 Posts
ouch what a bummer and a costly one at that too.
 

·
Registered
Joined
·
1,944 Posts
spot on, tibbo

This might be timely reminder for everybody to change out your coolant if you can't remember when it was done last, or you have just bought the car. The anti-corrosion additives in the anti-freeze don't last forever.

cheers
 

·
Two SC 61's = trouble
Joined
·
6,360 Posts
You could put an external cooler on it too.If it has a towbar it should have one if dealer fitted. Bungs will be needed to prevent coolant leaking from trans line connections..Radiators are not that expensive considering the damage thats done when they don't work properly....$300 to fix rad approx but $3k for auto and about the same for engine.. So is fixing radiator expensive ???? idts...
 

·
kez56
Joined
·
13 Posts
Discussion Starter #8
Folks...thanks for the input so far.

Tibbo, all of your comments have been taken on board and noted with interest. The car is booked in for tomorrow morning with the dealer she came from (still under dealer warranty). I have already advised them the problems I am experiencing and it will be interesting to see what they say and what they will replace/repair given that their service division told me all of the rectifications needeed are warrantable items!

Will post after I get her back.
 

·
Registered
Joined
·
1,944 Posts
At least it's under warranty, you can breathe a bit easier. :)


cheers
 

·
If Only I Had Lexus Power
Joined
·
827 Posts
Dont let them stinge you, make sure its done right
 

·
kez56
Joined
·
13 Posts
Discussion Starter #11
Just a short note...

All done...all is well

Tibbo....everything that you commented on that neededd doing was done..

Thanks guys.
 
1 - 11 of 11 Posts
Top