Ford Forums banner

1 - 6 of 6 Posts

·
Ranger Member
Joined
·
16 Posts
Discussion Starter #1
I think the torgue converter is shot in my Bronco, Cuz you can rev the motor in park and neutral but in gear it stalls the motor. Is there anything else it could possibly be? I'm not sure i want to put anymore money in this thing giving the fact that the body is so bad. Need advise, what would you guys do? I only paid $500 for it.

thanks!
 

·
Multi Ford Member
Joined
·
28 Posts
There can be other problems besides the tranny. Sounds more like the IAT is either dirty or history. This little jewel adjusts the idle. Look on the throttle body, it has wires running to it. unplug it, remove it from the motor, clean it with throttle body spray cleaner. The pintle inside of it should move freely. You can not make it move in and out but it should be clean and free. Inspect the holes that are in the throttle body, if they are cruded up, remove the throttle body- DO NOT CLEAN IT ON THE MOTOR. Once you have it off, clean the blades and bypass passages with the spray cleaner. reassemble. Probably will cure the problem, if not , post here again.
 

·
Bronco Member
Joined
·
69 Posts
could be a lot of things

Unfortunately it could be due to a number of things....
Have you done a tune up recently?

Another thing to look at is the EGR valve.....mine clogged up and made the truck run similarly...
 

·
Ranger Member
Joined
·
16 Posts
Discussion Starter #4
Would a clogged EGR let the motor rev in park and stall in gear??
 

·
Bronco Member
Joined
·
69 Posts
clogged egr

apparently what was happening on mine was that it was freezing (either open or closed i am not sure) causing it to run like crap especially in drive...

oh the other thing that would do it is a bad gasket between the carb and intake..... darn could be lots of things...

:)
 

·
Ranger Member
Joined
·
16 Posts
Discussion Starter #6
egr

by the way, I have a 302 EFI.
 
1 - 6 of 6 Posts
Top