Ford Forums banner

1 - 6 of 6 Posts

·
F-250 Member
Joined
·
20 Posts
Discussion Starter · #1 ·
My reader reported a "172" code, which the readers book says its a "Heated Oxygen Sensor, BANK 1, Lean"..

WHICH SIDE IS BANK 1???????

1991 Ford F-250, 5.8L EFI engine.

Thanks for any help.

Jim
 

·
F-250 Member
Joined
·
20 Posts
Discussion Starter · #3 ·
Thanks!!!!!

Think I should replace both of them, or just the one sending the code?

Thanks again for the quick reply!!!!!

Jim
 

·
Registered
Joined
·
10,552 Posts
normally i would replace both at the same time. it is a little more money to do it, but it is well worth it. I have seen the second bank throw codes right after replacing the one causing the problems.

just my thoughts. i know that others have only replaced one and not had a prob. how many miles you have on the engine will also be a factor in this decision. also pull a plug and check for fouling. It may be something a little more than an o2 sensor.
 

·
F-250 Member
Joined
·
20 Posts
Discussion Starter · #5 ·
The engine has 78,500 miles on it (orginal miles,not rolled over).

I looked it up in my Haynes manual and it also says replacement is way overdue....

The engine runs smooth, but the idle's faster than normal until the check engine light comes on, then it drops down to normal.
Cold engine starts without a CEL...

Jim
 

·
Registered
Joined
·
10,552 Posts
yeah replace both o2's

when was the last time you checked your plugs? check them for fouling. also look at the ends of the wires where the metal touches the plug to see if there is any arcing going on there.

that is what i would look at.

Hope that this helps.
 
1 - 6 of 6 Posts
Top