Ford Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
hello guy's. So i am racing a klde in the lemons series. i have the engine set into the car getting ready to start on the mounts. couple of things i am not sure about. first this engine has the tick that indicates the valve retainer issue so i am going to have to go into it to fix that. i was wondering is there anything i have to do to the oilpan so i don't starve it of oil in the turns? also the rubber mounts on the donar car were all broken i was thinking of making solid mounts and leave off the rear lower mount as there is just not room for it. i would also like to get a rev limiter/shift light on it how do i do that? anything else i need to do?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
So starting off here, everything is looking good so far but i have a couple of questions aside from the ones posted above. this car has a manual speedo i read somewhere that the K8de used a manual speedo drive is this correct? can they fit into the probe gearbox? Aaron
 

·
Super Moderator
Joined
·
7,733 Posts
Sorry for not responding earlier. Oil pan, not sure. Older cars with more room would put a deeper sump on the bottom of the block, if you have the room, you'd probably have to have something custom made. The other option would be to weld baffles in the existing sump, but you have to be careful as to not interfere with anything in the engine. I'd suggest leaving it as is and take a trial run to see if it's going to be an issue.

Rev limiter: depends on which one you buy, MSD carrys one that backs off the ignition rather than dropping it, but not sure if it's badge specific.

Not sure about the KLDE, but if you look on the output of the Probe's gearbox, you'll find the speed sensor, pull it and see if it looks like the end of a standard speedometer cable. It probably has an input to the PCM, but if you're using it for racing only, it should be just a nuisance diagnostic. After seeing the Prpbe's speed sensor, I'd say it's very likely.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
I did nothing to the sump as is was a thrash just getting the engine in and fired up. Funny even though i had tilted the engine forward 10+ degrees there seemed to be no oiling problem. But then i was pretty busy behind the wheel and only checked the gauges a few times in our 45 min sessions. The biggest surprise was the radiator (ebay two row miata aluminum unit) was completely adequate and not a hint of overheating. The engine never had one hiccup, fired up on the first crank and the cel light never came on. A situation that was amazing since i had cut large sections of the harness out. We did have a problem getting the fuel pumps to run. Since i was adding a lift pump and a surge tank we added a relay. Turns out when i removed the harness i just cut the whole harness where it went under the seat. There was a ground wire for the fuel pump there and took a while to find. Power was good but the inside wheel was spinning in the corners. The hybrid suspension (half 1800 ,half probe) just was too soft and you have never driven a car with more lean in the corners . On the bump stops on every corner! it did however dig in pretty good and only felt funny on braking on a downhill and darted around in a weird way then. But otherwise it was only 2 seconds slower than our other car (73 mini) the 1800 did several 2:22's around the "ridge". Next year i plan on putting in a complete probe suspension. Struts, sway bar, power steering. A fair bit of fabrication but if i can get a stiff enough front spring in there and the sway bar. i think a lot of the inner wheelspin will be taken care of. The brakes on the other hand were awesome as I had done the 12" inch rotor and mx6 caliper upgrade and the rotors were a nice shade of blue after the race. but the pads will only stand up to about 12 hours on the track. But since the track does not have lights for the night we run two days anyway and are used to changing pads bleeding and fixing anything needed for the next day. Next year i plan on getting the external coil setup and some power upgrades done also. I am sure we will be going over some of those in the time in between. There was another probe a 2 liter 4 cyl out there but i never saw it while i was driving Thanks everybody.
 

·
Super Moderator
Joined
·
7,733 Posts
Sounds like you had some fun with it. Hope your suspension mods help!
 
1 - 8 of 8 Posts
Top