Ford Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
So my 96 probe gt 2.5 has been idling EXTREMELY high like 4000 rpms. I had a iac code and replaced that still did it replaced TPS still does it. But when I was setting the TPS the fan way, it never turned off. Anybody have info?
 

·
Super Moderator
Joined
·
9,333 Posts
Did you try cleaning the throttle body? If you tried in place with just a spray, it probably didn't do much. That's a fairly high idle even for a dirty throttle body.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Did you try cleaning the throttle body? If you tried in place with just a spray, it probably didn't do much. That's a fairly high idle even for a dirty throttle body.
Yeah I took it apart and cleaned it before I replace the TPS and the iac.
 

·
Super Moderator
Joined
·
22,051 Posts
After cleaning and replacing the iac valve is the throttle body spindle / butterfly closing o.k and not sticking ? Along shot but try disconnecting the MAF
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Yeah I tried that when I was diaging it but nothing happened, I was told it could be an intake leak but I could find one and that's a pretty high idle for an intake leak isn't it?
 

·
Super Moderator
Joined
·
9,333 Posts
I'd say it was high, but not necessarily impossible under the right conditions. It sounds like they throttle blade isn't closing fully. See if there's a gap between the blade or the seat on both sides.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
I'd say it was high, but not necessarily impossible under the right conditions. It sounds like they throttle blade isn't closing fully. See if there's a gap between the blade or the seat on both sides.
Alright I'll check it again.
 
1 - 7 of 7 Posts
Top