Ford Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My daughter's Ford Escape 2016, suddenly shows an error that says something like activate hill start not available, and then her speedometer doesn't work. There is some yellow icon that looks like a car with squiggly lines under it as well as another she cannot remember right now. It happens then stops on and off for the past day. Is this something simple or do we need to go to the dealer?
Thanks
 

·
Super Moderator
Joined
·
22,544 Posts
SOMETIMES systems like hill assist will shut down to conserve power when there’s a battery or charging issue. , worth LOAD testing the battery voltage before getting too involved


Moved to Ford Escape section
 

·
Super Moderator
Joined
·
9,616 Posts
Could also be a wheel speed sensor. Ties into traction control, stability, etc. Pulling the codes will tell you more. Load testing is free, so you may want to go that rout first.
 

·
Registered
Joined
·
3 Posts
Thanks for the info, I'm having a similar issue. I'm thinking it might be a sensor, my battery was new in December.
Speedometer Trip computer Odometer Tachometer Motor vehicle
Speedometer Trip computer Gauge Motor vehicle Odometer
 

·
Super Moderator
Joined
·
22,544 Posts
Could be a sensor but wont cost anything to get your battery LOAD tested to check overall condition , even though replaced 10/11 months ago , eliminates a possible cause . Might want to check alternator charging rate at same time as a simple 2 min test
 

·
Registered
Joined
·
3 Posts
Had battery/alternater/starting tested, scanner read low voltage, replaced battery (under warranty) did not fix the issue. Also, scanner read bad left front ABS and speed sensor. Note, my 2014 Escape has 305,000 miles on it and never really had any issues until it hit 300k.
Wheel Car Tire Automotive side marker light Vehicle
 

·
Registered
Joined
·
3 Posts
Update: Went to replace my ABS Sensor, found that when I had my struts replaced, they didn't secure the wires for the ABS Sensor and the wheel rubbed through the wire. Problem solved.
Automotive tire Electrical wiring Gas Valve Cable
 
1 - 9 of 9 Posts
Top