Ford Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3,023 Posts
Discussion Starter #1
About a 2 weeks ago I was just driving along and while turning the steering wheel it suddenly became harder to turn, at the same time emitting a grinding noise from the steering column area. This went away after a couple of secs(both the noise and resistance).
Before Wednesday, this had happend probably no more than 10 times since that first occassion, but on Wednesday Thursday and Friday it became more and more common.

I adjusted the steering wheel to its maximum height and it temporarily stopped it but it eventually came back again(could have been a coincidence though....)
Any ideas on whats going on?

If its the Power Steering pump why would there be a grinding noise coming from the steering column?
Im going to pull out the horn and cruise electrical contacts tommorrow to see if they are causing it, but id find it hard to believe they could cause so much resistance?

Also ever since I bought car, the steering wheel has squeeked while turning

If it makes any difference its a factory Momo Wheel with Cruise
 

·
European Member
Joined
·
84 Posts
There is a bush at the bottom of the column which is easily damaged if the wheel has be lowered too far. You might want to check this.
 

·
MkII Cortina Owner
Joined
·
529 Posts
Hey,

I have a similar problem with the EDV8 I've just bought. Its power assisted, but on occasion the assistance disappears. No noise, no grinding/binding of the column. Its just like the car decides that it will be a manual steered car for a minute. It has never happened on the move/highway speeds only in carparks. The extra weight has had one unexpected bonus - the girlfriend, the mates and the family all dont want to drive it for fear of parking it! :s3:

So what do you guys think? Do you think a seal/bearing could have perished - it only had a genuine 26500 on the clock when I bought it. So it has spent much of its life in the garage watching the world go by. The car is completely stock - save a set of *whispers* hotwires with 205s that the old guy who had it before me had fitted.

Cheers in advance for the replies....

L8a,
Prud
 

·
Registered
Joined
·
3,023 Posts
Discussion Starter #5
Thanks for the help guys.

I pulled off the steering wheel and the column with the indicator/wiper stalks on it and came to this circlip on the stering shaft, and what looks like a bush or bearing behind it? The squeeking seems to be coming from this area?(just the slightest movment of the steering shaft causes this squeeking) I didnt really want to go any further than this cause I had no idea of what I was doing.....

Also I adjusted the reach of the steering wheel slighty inwards and it seems to have stopped the resistance and grinding(knocks on wood) Obviously this isnt a permanent fix.....

PS The bush at the base of the column(the one right at the firewall?) and the steering linkage appears to be fine(well to me)
 
1 - 5 of 5 Posts
Top