Ford Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
2008. 2wd 3.5 83000
starts and runs great, very smooth
light to moderate acceleration smooth as silk
moderate to heavy acceleration it will stumble and buck and flash a p0302
this seams to happen only when under a load
swapped coils and plugs seeing if the problem followed either of those
no joy
I still need to swap injectors

one thing I noticed when it starts bucking , no matter what speed its at, if I turn off o/d
it stops bucking. I even turned o/d off and did the whole scenario again, there was no bucking
I'm still gonna swap injector because I still keep getting a misfire on 2. ill also run a compression check just to be sure
but I'm wondering about the transmission

by the way all the fluids are fresh and full

has anybody run across this and were you able to solve it?
thanks
 

·
Super Moderator
Joined
·
9,749 Posts
How does #2 plug look in comparison to the others?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
update. I did change the injector, there was no change
it occurred to me that the code would appear after the stumbling started but would turn off about a half mile after it stopped stumbling. I got to wondering if the transmission could be bucking hard enough to cause the misfire
so I power flushed the transmission thinking maybe if there was any contamination maybe the shift solenoid was sticking

sure enough after completing the above mentioned service a 50 mile drive and no issues at all

is it just me or is the mach E the ugliest mustang ever?
 

·
Super Moderator
Joined
·
9,749 Posts
Good to hear, and it ain't just you that hates the E.
 
1 - 4 of 4 Posts
Top