Ford Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
i have a 93 ford escort LX.couldn't find the manual for type of tranny fluid so i put in type "F".The tranny has been slipping when cold taking off.It started doing it a little and is getting worse.Couldnt see any fluid on dipstick so i added 2 quarts.haven't drove it but let it idle in gear for 5 mins after adding to a allready warm engine and rechecked the fluid.Looks like it's where it should be but kinda hard to tell the fluid looks more clear then red on the dipstick and after dumping fluid down there the whole stick gets a bit oily.i'll check it again tomarrow.The slipping stops after car is warm.The sound it's making in gear is what disturbs me.could just be some loose junk under there rattling or the exhaust leak.there's just no way to tell where the noise is coming from.What i need to know is did i put the wrong type tranny fluid in.if so maybe i can take it to jiffy lube and get it changed before further damage occurs.I'd hate to spend the money if the tranny is about shot anyway.I remember my old 350 chevy tranny slipping.It was just a matter of weeks before it went completely.though this escort doesn't slip in the same way.its more like as if it isnt engaging all the way into gear or some shit.maybe the fluid adding will fix it or destroy it who knows?
 
1 - 1 of 1 Posts
About this Discussion
0 Replies
1 Participant
reeler
Ford Forums
Ford Forum is a community to discuss all things Ford. Check out our discussions on the Ford Escape, Mustang, Edge, F-150, Raptor, Explorer, Focus, Fusion, Fiesta and more!
Full Forum Listing
Top