Ford Forums banner

1 - 8 of 8 Posts

·
Yeah .... I am here
Joined
·
751 Posts
Discussion Starter #1 (Edited)
Trouble Getting The Windsor To Kick Over

in the last 6 months i have noticed the XR8 doesnt kick over like it used to. The starter is still kicking over like it always has. But it can be up to 5 seconds before it starts. Its standards appart from iridium spark plugs and top gun leads. Any ideas, or anyone had similar prob ?? and what did you do ?
 

·
Lamahs approve of manuals
Joined
·
1,382 Posts
I'm kinda of similar (although not 5 seconds, maybe 2, 2.5).
It was better when I had an aftermarket (super-duper) coil, but that one died, so I'm back with the (slower) original . . .
Once she's kicking over, your basically looking at either fuel or spark . . .
 

·
BA'o'Matic 100% working.
Joined
·
3,838 Posts
If you turn the key to acc so fuel pump primes and do this 2 or 3 times, does it then fire first go like it used to or not ??
 

·
Yeah .... I am here
Joined
·
751 Posts
Discussion Starter #6
Dellboy999 said:
If you turn the key to acc so fuel pump primes and do this 2 or 3 times, does it then fire first go like it used to or not ??
yeah i tried that, and it starts pretty much straight away.

i will change the fuel filter, its done 73000kms, so i guess its time for a new one !

!Gn|T|0n - man i read that thread of yours, took like 10 minutes, i hope some miricle cure arrives !
 

·
i pity tha fool
Joined
·
1,040 Posts
find the same.. doesnt kick straight away... takes a few winds from the starter..

prob me no letting the pump prime properly.
 
1 - 8 of 8 Posts
Top