Ford Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
367 Posts
Discussion Starter #1
have posted this in windsor engine tech but thought I try here. car runs fine when cold but when it warms up to normal operating temp it's very flat; sluggish from a stand to about 2500 after that it seems to be fine. can anybody give me any idea what the problem is ?

MIKE
 

·
oh no! I've gone ford mad
Joined
·
134 Posts
I don't know much about windsors but I'd reckon you best bet would be to buy a repair manual and check all the sensors according to it....

Thanks
Craig
 

·
feed me hey
Joined
·
4,692 Posts
Take the engine cover off and youll see the coil and it has a square thing around it. Look down the front edge for signs of white deposits. When I couldnt get mine to run right I noticed this but thought nothing of it. When I was seeking advice at the local garage, there was an EF XR8 with the exact same thing except someone had tried to repair it with some sort of goop. I havent replaced mine yet. I don't even want to know the cost of a coil for the V8
 

·
YES its a 5 Speed!!
Joined
·
2,242 Posts
maybe the timing is out?
 

·
Registered
Joined
·
367 Posts
Discussion Starter #7
have checked the coil no signs of any cracks; timing is fine also
 

·
known as tibbo
Joined
·
2,033 Posts
1. Heat range of the plugs your using?
2. Check the fuel filter
3. Check your accel cable is OK (not really heat related but more common than you think)
 

·
Registered
Joined
·
367 Posts
Discussion Starter #9
plugs are new but are same type of plug that have always been in it; fuel filter is new
 

·
known as tibbo
Joined
·
2,033 Posts
so it free revs nice and hard in neutral when you first start it up then? and the hotter it gets the lazier it gets, is that in gear or does it still rev as freely in neutral when its warm? Did it just start doing this one day or has it been getting worse over time?

Maybe find someone on the coast to get the (if any) codes out of it?..
 

·
Registered
Joined
·
367 Posts
Discussion Starter #11
Yeah it started overnight; thought i might get it tuned a a dyno next week. anybody know whoes got a dyno here on the Gold Coast?
 

·
Registered
Joined
·
367 Posts
Discussion Starter #13
thanks tibbo have already sent a pm to gm detoryer
 
1 - 13 of 13 Posts
Top