Ford Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
I have a manual XR6 EF. The clutch has always been heavy. But sometimes it is perfect and alot lighter especially in dry warm weather when I have not driven it for a while. Other times, especially with weyt weather and a load in the car it is really!! heavy and feel a bit notchy. I had the clutch rep[laced 4 months ago and it does the same thing. I know the XR has a heavy clutch but is this normal, or is there a problem.??
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
I can not remember the brand, but it did it with the original Ford one also. When the cabel is lubricated it sometimes frees up but then goes again.
 

·
I want a turtle!
Joined
·
2,635 Posts
Hi AndrewP,

Have you had a look at the pedal box?

The bracket that the clutch pedal sits on has a habit of bending.

Also - you might want to check the firewall where the clutch cable is.
On mine the firewall cracked. the panel beater that fixed it up said it happens a lot on the EA - EL falcons.

:)
Kelli S
 
G

·
XR8chic has a point there, however, your (AndrewP) problem has something to do with lubrication of the clutch... As to the type, I wanted to know if it was Performance or Stock... I'll check what they have to say at work and I'll get back to you tomorrow...

Kieran.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #6 ·
Thanks for the hints and help everyone. The clutch I have is a good quality stock. My mate fitted it to my car, he is a reputable local mechanic that I trust (he recommended the one I have now), the clutch before changing as I said was the original, and I still had the same problem, but worse. Last time the cable was lubricated it made no difference. Im not sure what is happening, but I can definitely tell you that it gets very hard in wet weather. I look forward to any ideas you can give me, I will get my mate to check what you have said so far.
Regards AndrewP
 

·
Australian EF XR6 Member
Joined
·
155 Posts
Andrew

Sounds like exactly what happened to mi EF XR6. As Kellie suggeted, check the pedal box.

I replaced cables etc until the car was finally un-drivable and we found that the pedal box had "come apart"

Good luck
Simon.....
 
1 - 7 of 7 Posts
Top